Cisco IOS consists of a CLI, below some basic commands to use:
Cheatsheet
To enable to enter privileged exec mode:
Enable
To return:
exit
Change hostname of device:
hostname [name]
Enter global config to make changes to terminal and enter global configure mode:
configure terminal
Enable a password:
enable password [...]
Encrypt the password(weak):
Service password-encryption
Enable a better encrypted password:
enable secret [password]
Show the current running configuration:
Show running-config
Save config:
Write
Write memory
Copy current config to start-up config:
copy running-config startup-config
-------------------------------------------------------------
MAC adressen op switch:
Show mac address-table
clear mac address-table dynamic
clear mac address-table dynamic address [MAC address]
clear mac address-table dynamic Interface [Interface name]
------------------------------------------------------------
Op Router:
show ip interface brief
Laat informatie over de interfaces zien.
configure terminal
interface gigabitethernet 0/0 / int gig0/0
ip address 10.255.255.254 255.0.0.0
no shutdown
show interfaces
show interfaces g0/0
Om de omschrijving van een interface te zien:
show interfaces description
beschrijvingen kunnen handig zijn in de toekomst:
int g0/0
description [omschrijving]
--------------------------------------------------------
Switch commands:
show ip interface brief
show interfaces status
show interface
Snelheid installen op een interface:
int f0/1
speed ?
speed 100
duplex ?
duplex full
omeschrijving toevoegen:
description [omschrijving]
Om meerdere interfaces tegelijk te bewerkern/configureren:
interface range f0/5 - 12
nu kunnen we bijvoorbeel van de hele range de omschrijving aanpassen en via no shutdown/shutdown ze aan en uit zetten.
-------------------------------------------------------------
ROUTING:
Ip adres op interface instellen:
Interface G0/0
ip address 192.168.13.1 255.255.255.0
no shutdown
Routing table:
Show ip route
IP Route instellen:
ip route 'ip-address' 'mask' 'next-hop'
G0/0
ip route 192.168.1.0 255.255.255.0 192.168.13.1
G0/1
ip route 192.168.4.0 255.255.255.0 192.168.34.4
Je kan ook een interface instellen inplaats van een IP adres van een interface:
ip route 'ip-address' 'mask' 'exit-interface'
VOORBEELD:
ip route 192.168.1.0 255.255.255.0 G0/0
De next-hop kan ook worden toegevoegd
ip route 'ip-address' 'mask' 'exit-interface' 'next-hop'
VOORBEELD:
ip route 192.168.4.0 255.255.255.0 G0/1 192.168.24.4
Een default route is de meest niet specifieke route.
Een default route word vaak gebruikt om verkeer naar het internet te routeren.
VOORBEELD:
ip route 0.0.0.0 0.0.0.0 203.0.113.2
R1
192.168.4.0 255.255.255.0 192.168.12.2
R2
192.168.4.0 255.255.255.0 192.168.24.4
192.168.1.0 255.255.255.0 192.168.12.1
R4
192.168.1.0 255.255.255.0 192.168.24.2
===================================================
An access port is a switchport which belongs to a single VLAN,
and usually connects to end hosts like PC's.
Switchports which carry multiple VLANs are called 'trunk ports'.
show vlan brief
Een vlan configureren:
interface range g1/0 - 3
switchport mode access
switchport access vlan 10
andere manier om een vlan te maken is:
in config mode
vlan 10
in config kan je ook een naam instellen:
SW1 (config)# vlan 10
SW1 (config-vlan)# name HR
Trunk ports:
switchport mode trnk
ALS JE EEN ERROR KRIJG EERST:
switchport trunk encapsulationn dot1q
show interfaces trunk
Switchport trunk allowed vlan 10,30
Nu mogen vlan 10 & 30 op de trunk port
switchport trunk allowed vlan add 20
switchport trunk allowed vlan remove 20
switchport trunk allowed vlan allowed
nu mogen alle vlans op de trunk, net als bij de default state
Router on a stick:
Alle vlans worden via sub interfaces gerouteerd.
interface g0/0
no shutdown
interface g0/0.10
encapsulation dot1q 10
ip address 192.168.1.62 255.255.255.192
interface g0/0.20
encapsulation dot1q 20
ip address 192.168.1.126 255.255.255.192
interface g0/0.30
encapsulation dot1q 30
ip address 192.168.1.190 255.255.255.192
When a switch receives an untagged frame on a trunk port,
it assumes the frame belongs to the Native VLAN.
native VLAN is aan te passen middels:
switchport trunk native vlan vlan-number
=====================================================
Spanning tree disabled redundant ports by putting them in a blocking state.
show spanning-tree
show spanning-tree detail
show spanning-tree summary
show spanning-tree vlan 10
Enable Rapid spanning-tree:
spanning-tree mode rapid-pvst
=============================
Configure the EtherChannel load-balancing method on the switch:
port-channel load-balance
display information about the load-balancing settings:
show etherchannel load-balance
Configure an interface to be part of an EtherChannel:
channel-group [number] mode {desirable | auto | active | passive | on}
display a summary of EtherChannels on the switch:
show etherchannel summary
Display information about the virtual port-channel interfaces on the switch:
show etherchannel port-channel
=============================